Download Minecraft

Minecraft Mods Texture Pack Maps Skins

How to Install Minecraft Forge 1.7.10/1.7.2/1.6.4

Jul 23, 2014 BY 252 Comments

Minecraft Forge is an API providing extra modding capabilities. These capabilities have been added to provide support for the different mods using the Forge. As of today, the forge contains. If you want to installed the Minecraft Forge API / compatibilty layers. You only need to do this once for all mods requiring it. Note that certain mod may include Minecraft Forge in their code, in which case you don’t have to install the forge, but it’s no harm to add it on top of the existing installation. Want to install and download this Minecraft Forge API ? see my post below

Minecraft Forge Features

  • Infinite terrain and sprite indexes
  • Support two-pass rendering
  • Custom redstone connection direction
  • Override block replacement/deletion
  • Secondary properties for block (isNormal, isReplaceable, isAir, isBurning)
  • Allow an item to have the first callback on a mouse click
  • Custom explosion resistances by block and direction
  • Custom filled buckets
  • Custom armors
  • Modification of list of mineable objects
  • Advanced configuration files

How to Install Minecraft Forge 1.7.10/1.7.2/1.6.4

Thank to SpaceToad for makes this awesome Minecraft Forge Mod.

For Windows users, you just have to run install.cmd. If you’re on linux, you need to copy files and apply patch manually for now, let me know if you got any trouble there. A install.sh for linux users too is on the way, but in the meantime, let me know if you have any setup problems.

Minecraft Forge Installations for Minecraft

  1. Download Minecraft Forge
  2. Open your minecraft.jar
  3. Drag the mod loader files over
  4. Delete META INF
  5. Drag over forge files

So Minecrafters!, as always we need your comment to complete this Minecraft Forge API post. You might be want to add for complete details and features or want to share tips, trick or even tutorial about this MCForge. Then feel free to share and do not hesitate to. Ok guys, until next post on another mod, have fun and thank you for visiting my post about Minecraft Forge API

DOWNLOAD LINKS MINECRAFT FORGE

Download Minecraft Forge 1.6.4 API

Download Minecraft Forge 1.7.2 API

Download Minecraft Forge 1.7.10 API

Incoming search terms:

  • minecraft forge 1 7 2
  • forge download
  • minecraft forge 1 7 10 download
  • minecraft forge download 1 7 10
  • minecraft forge installer
  • forge 1 6 4
  • forge downloads
  • minecraft forge api
  • minecraft forge 1 7 10
  • 1 6 4 forge

Tags: , , , , , ,



252 thoughts on “How to Install Minecraft Forge 1.7.10/1.7.2/1.6.4”

Hello! I have installed all the components that required to run MCForge and a few mods that requires it (Balkon’s Weapon Mod and PlasmaCraft) but it still gives me black screen after trying to create a world. What went wrong?!

If you installed all at once then tryed to play minecraft, then thats the problem. When you want to download a lot of mods, all you have to do is open and login to minecraft when 1 mod is installed. If it works, only THEN install 1 more, and so on, until all the mods are on and it should work!

but i need modloader mp cause i want to install the new modern weapons pack 1.6 for minecraft 1.2.5.
this is the order i hae to install it in

modloader-pass
modloader mp-pass
turbomodulethingy-pass
minecraft forge-unknown error
player api-dnf
flans mod-dnf
nmw pack-dnf
sop mod-dnf

1. You need modloader to run any type of mod.
2. You must delete your META file (or you will still get a black screen…)
3. Make sure your version of MC is the required version for this mod.

Hope this helps.

How to install forge
download the reccomended version of universal
open up minecraft.jar with winrar or 7zip
open forge universal zip file with the same archiver(winrar or 7zip)
drag all of the forge files into minecraft.jar
delete only the mojang files in META-INF
done!!!!

try deleting .minecraft in appdata roaming and redownloading minecraft from minecraft launcher and then install forgeworked for me when my files randomly got deleted

Okay dude right before you copy paste and replace all the mc fordge files in .bin go into .bin find and remove (delete) the META INF folder and that will fix your black screen problem okay dude? cool. =3

You get black screens becuase it isnt for 1.2.3, it is still for 1.1

They really should not say this unless it really is updated. It only tells you it isnt for 1.2.3 in parenthesis below the link

Hey, tell me how to download Forge 1.2.3 API Mod Client?
When click on the link there is no button to download … What should I do?

press minecraft forge client 1.2.3 API mod client then is there build artifacts then minecraftforge-client-1.4.0.46.zip then have ye the download!!

Yeah this is definitely still broken deleted my META-inf and also carefully got the files from the folders inside the forge file to insure that nothing was skipped over and still a black screen so please fix it asap

Yeah, i need the Forge 1.4.0.46 client but i cant get it D: does anyone know a link where I can find it?

Also, i need it for installing Equivalent Exchange……anyone know how to do that?

Thats It! I cant take it anymore! every time i download the client zip im getting only ONE folder for the mod its not even a mod folder, its just saying who made it and why it ways made! plz reply if you have the answer to my woes or have a different download link.

This Forge make my game is down when i enter in the Nether!

Show the Text: SAVING CHUNKS, and show the BlackScreen!

Please Help-me!

Most of the time when the saving chucks error happens it is because the mod you are using is somehow conflicting with other mods you might have to delete your old worlds. D:

Hey I’m having a problem with the black screen and I tried everything to install the mod with buildcraft. I installed buildcraft right, and it works on it’s own, but not with redpower or better than wolves. PLEASE HELP! D:

The problem is simple, the link in this post redirect to the last version of Minecraft Forge, so just click on Forge on the top left and download the [Recommended] 1.4.1.59 version and it will work with Minecraft 1.2.3, the last update is for 1.2.4 ;)

if you are doing this on linux :
unpack the forge stuff before copying it into the jar.
if you copy it from the archive manager into the other archivemanager it ommits some files … (copying from zip to char works for ModloaderMP)

cheers

When i click on the download button it doesn’t download it just takes me to this random website. Where do i click to download?

you click the bottom link under the server button that says mirror next to it, u should then get adfly and the download starts after

I have the problem,when start minecraft mojang logo comes,then te game says minecraft has crashed!
PLZ Help

This gives me the update minecraft stuck at 80% but it says done and it freezes like that (mods= Modloader & optifine)

I cant download… when i click on download link i 1. dont know what to do 2. dont think the link is there and 3. CONFUSED

I really think you guys should make an exe that would already patch the minecraft.jar with all necessary files, but I guess that installing mods is supposed to be a pain in the ass. Can’t get it to work at 1.2.5.

Hey I have the “done loading” screen that doesn’t go away. I’ve watched countless videos on how to install it and I follow the directions perfectly but noting works. please help!

As allways with any mod for minecraft, it doesnt work, and YES META_INF is deleted, and followed about every tutor, not a signle mod works, result black screen with 1.2.5

Some mods even can get my CPU crazy, it after loading manycraft it speeds up, temp goes up, but utilisation stays down..

Never EVER i seen with any mods in any game, this kind of misery, and i have gotten some strange mods in games working that aint even mod supported like minecraft, this one… big fail

So this adds some new stuff huh? Well the installation instructions is really not that good.

Drag the classes from the root directory in the mcforge archive to where?
Drag the forge directory in the mcforge archive to where?
Drag the net directory in the mcforge archive to where?

And they seriously expect donations for this? How can I possibly donate to something that doesn’t have a properly written installation manual. Reminds me about IKEA, that’s why I never buy furniture there because their sloppy instructions.

If you get a black screen this is what you do:
1. Download a clean version of minecraft
2. Open the minecraft.jar
3. Delete the META-INF folder
4. Put the modloader files in the minecraft.jar
5. Run minecraft until you see the main menu
6. Put Forge files in minecraft.jar
7. Run miencrraft until you see the main menu
8. make a “mods” folder in the .minecrat folder
9. Put any mods you want in there
10. Enjoy the mods

i tried and it’s not working, and when i install modloaderMP inside the game, it puts meta not found. can you help me?

i did this to the letter it worked fine with just modloader so i closed minecraft and put forge into the jar started minecraft again but all i get is the “minecraft updating” “done loading” screen with the progress bar not totally full
minecraft 1.3.1
vista operating system

I have installed the Forge for 1.2.5 (And yes i have 1.2.5) but all of the animals in the game are invisible, Their not gone because i can still kill them and get stuff from them. I am also invisible, i cant see myself. Ive looked and all the right texture files are there. Im so confused.
I dont really know what im doing wrong

I have:
Modloader
Modloader MP
To Many Items
Minecraftforge client

and yeah i deleted the Meta-inf
(I also used mc patcher for the HD textures and Font B4 i installed the mods manually)

Some mods say I need to install Modloadermp and forge (client), but when I did it on my server, it said I cannot have both. Would it work on the client?

omg the forge messed with my game laged it, removed all my mods, and caused blackscreen and yes it was 1.2.5 the forge is usless

I have downloaded the client version because on my magic launcher, it told me to get forge, so when I did get it, it said that there were 2 errors. Is there a way to fix that?

Go to desktop and find the “Go” pull down menu. Find the “Go to Folder” choice.
Type the following…

~/Library/Application Support/minecraft

You’ll never find it digging around in the Finder because it’s invisible.

Please help,im try to install the *** forge api on linux,and i can’t do Nothing!
It give me a black screen,and i try all:
Y get a fresh Minecraft
I deleted Meta-inf
I don’t have got any mods.Only modloader and forge
I try ALL.
Please help,please….I don’t like linux for this reason.
**** Linux!
And,i don’t find any patch for this ******.

Okay, i installed Forge Api and Modloader, then i run minecraft… it works perfect UNTIL i create a new world…. i create a new world and it crashes.

I tried several times to install this and I have Mod loader already installed and having it run well though when I install this I get stuck with a unfinished Done Downloading screen, how would i resolve this problem?

Im having the same problem witht the unfinished “done downloading” screen when i try to run minecraft. but im trying to run snapshot, not this program. help? xD

Running MC 1.3.1 with magic launcher
Downloaded Minecraft Forge 1.3.1 API Mod Client
ML says “not compatible”

where is the Problem?

I had the same problem. I do not know how to fix it. I can’t even download from the link on this page because my browser says 404 not found.

Does anyone bother to read the jenkins build info?

It clearly states 3.4.9.171 is the Final build for 1.2.5 NOT for 1.3.1

can’t get it to work. (i have a legal minecraft 1.3.2)

1. downloaded the above 1.3.2 file
2. openend de the jar file
3. removed the metinf dir
4. dragged and dropped the files form the downloaded file in the jar file
5. closed everything and started minecraft

Result … can’t find ANY change. I thoght i’ld find a button or something with which i can choose what mod to start?

Can anyone help this total NOOB ??

Mant thanks!

I have magic launcher, so i have all my core mods in ModMagic folder, in Magic Launcher Setup, there are 23 errors on minecraftforge-universal-4.0.0 and NO MODS FOUND on CodeChickenCore which is both requied for playing with NEI, i can start Minecraft normally, create new world but everytime i try to open my inventory ingame, game crashes. help me pl

everything was great i instelled it and it worked but after i added a mod to the new mods folder it get black i’m tried everything but it doesn’t work i even reinstelled it why i can pot mods there

you do not have to use modloader anymore. the forge has one in it called FML or forge modloader i don’t know what happens after it installs but I’ll find out when i do.

PS
I dont like forge

I can’t download the client version because when i open it my computer opens a new tab and it displays the “internet explorer can not display the webpage” and I’ve tried refreshing it and closing adn reopening the tab and it won’t work

links not working! also i must say beeing new to MineCraft – there’s allot of going from one place to other and get this first, then do this…….. etc be nice if some made the whole process easier for what ever you wanted to do!! ps LOVVVVVVEEEEE the Game

That link doesn’t seem to work, looks like its down for a while, it will be back so be patient, if not. We not gonna download the mod everytime!

This could be a Website malfunaction because there may be database crash.

Black Screen after Mojang

Anyone knows solution?

Installed Modloader 1.3.2, ModloaderMP 1.3.2 (client) and Minecraft Forge 1.3.2

Please, don’t install ModLoader 1.3.2. Because its own Modloader codes inside mod. If install Modloader and Forge, you see Black Screen error.

I installed this but every time I play a few seconds after I start my minecraft crashes. :| How do I fix this? I really want to use the balkons weapon mod.

I have the correct version and only other mod is optifine (which works) but it crashes after Mojang screen. I tried a fresh reinstall of MC like the Forge page suggests, but it still crashes everytime. Any ideas?

Hey folks,

I just ran into the “stuck on black screen” problem when updating to forge for 1.4.2 and here’s how I fixed mine: turns out I had older mods for 1.3.2 in the %appdata%/mods and that’s what was killing it. I forgot those were there. Once I got rid of them (and reinstalled forge, but that may not be necessary if you’ve done it correctly already), it launched just fine!

Hope this helps someone!

I downloaded and installed FML, yes i did delete META,l yes it is the right verision, its the only mod installed. but the screen is stuck at “done loading” whats wrong?

can SOMEONE please get this working.
it always gets stuck on the loading screen.
please help.
it is not useful to just say
“it is stuck”
SEND FRIGGN HELP!

i dont get it, it says “Minecraft Forge 1.4.5 API”. why the f—k wold it be for 1.2.3 or 1.3.2 or 1.4.4. or whatever if it says “1.4.5″, it just seems realy weard.

Ps.The 2nd link works for me.

All Of YOU GUYS ARE WEIRD I DID THIS MOD WITH NBTEDIT AND IT WORKED SO WHY
DO PEOPLE NOT READ THE INSTALLATION
IF YOU READ THE INSTALLATION IT WILL WORK HERE IS THE INSTALLATION

Minecraft Forge 1.4.5 API Mod Installations for Minecraft 1.4.5

Download Minecraft Forge 1.4.5 API
Open your minecraft.jar
Drag the mod loader files over
Delete META INF
Drag over forge files

HERE IS THE DOWNLOAD LINK:

http://adf.ly/Ezuuj

COPY THIS LINK IN THE SEARCH BAR

can someone help me i dont know how to get industrail craft and when i downloaded minecraft forge it came up with heaps of random files and theres no download button plz respond

Which download am I supposed to pick javadoc, universal, or src? What the fuck…… I need this mod because every mod I want requires it.

when i do what it asks in the installing instructions it comes up with an error when i try to launch minecraft and i end up needing to delete the whole .minecraft folder, it says “minecraft cannot launch in it’s current configuration
consult forgemodloaderclient-0″, is there anything i can do about this?

Download the one that isnt all the way at the top, thats 1.4.5 I think. Look for the one that says 1.4.6 forge then download universal!
Tell me if this helped

Ok, I installed the latest recommended install for Minecraft 1.4.7. I deleted the META-INF files, from vanilla minecraft. I installed minecraft forge correctly and I ended up with a black screen after it saying validating, launching…

When I install forge for 1.4.7 on my minecraft(1.4.7) and I use the premium launcher, my minecraft crashes, when I use the cracked launcher instead, it doesnt crash, I would like this to be fixed because now I can only go on cracked minecraft servers, and I would like to be able to go on every server

so new version of Forge (1.5) does not work on smp side

I have set up everything and I keep getting FML not installed
previously (1.4.7) it worked fine on my server with mods

For windows users, that are new to this, download the src file, extract the contents to a folder, and double-click install.cmd in the root folder. NOTE: If this is your first time installing Minecraft Forge, you need to download and install the Java Development Kit (JDK) from Oracle PRIOR to running install.cmd.

This process will take a long time. You must be connected to the Internet at the time you run it. It will download additional files in the process, so if you only see a black screen with no feedback, just be patient while it’s downloading those files.

hey, ummm … I’m downloading the sorcery mod and i’m wondering whether to delete the Meta-inf inside the actual forge .

I put forge in to the 1.6.2 jar and it doesn’t work, but the game works normaly. I put modloader in first then forge and the game crashes.

Leave a Reply

Your email address will not be published. Required fields are marked *