Download Minecraft

Minecraft Mods Texture Pack Maps Skins

Magic Launcher 1.7.10/1.7.9/1.7.2

Jul 12, 2014 BY 96 Comments

Magic Launcher – Download Magic Launcher 1.2.5 for Minecraft. Hello minecrafters! want to easy install and changings your mods in one click, so here for you called Magic Launcher. The Magic Launcher is a new Minecraft launcher which can load mods dynamically without changing or patching the minecraft.jar. No more mod installation problems, just select your mods and enjoy. Sound interesting right, if you want to download and install this Magic Launcher just see my post below

Magic Launcher  Features

  • Minecraft
    - selectable minecraft.jar
    - automatic version detection
    - configurable window size, also maximized
    - selectable minecraft folder
    - selectable java executable
    - java memory limit
    - java custom parameters
    - show error log
    - remember user
    - configuration profiles
  • Mods
    - load mods dynamically without changing minecraft.jar
    - automatic mod compatibility checking
    - external mods detection and compatibility checking
    - shortcut to external mods folder
    Design (screenshots)
    - Minecraft style
  • News
    - Minecraft
    - Reddit
    - Twitter
    - Blogspot …

Magic Launcher Changelogs

  • added option to turn off news tabs for faster startup, fixed Forge detection, auto-resizable message dialog
  • added custom directory support for Mac and Linux
  • added checkbox ExternalMods to disable or enable all external mods at once, fix for external mods after a crash, fixed some hanging file locks on external mods
  • fixed offline mode to start correctly
  • copy profiles, external mods can be deactivated per configuration, automatic mod requirements checking (ModLoader, ModLoaderMP, Forge, GuiAPI), detection of duplicate mods, detection of internal mods placed in external mods folder, detection of empty or not unpacked mod archives.
  • fixed external mods folder to be under custom base folder
  • added configuration profiles, window size, window maximized, java path, java parameters and base folder, fixed non-ascii paths, allows mod from jar files, “Manage” creates folder “mods” if not existing
  • fixed some problems
  • textured buttons, more complex compatibility checks, gray inactive mods, checkbox Check compatibility

Magic Launcher 1.7.10/1.7.9/1.7.2

Magic Launcher ToDo

  • Check for new Minecraft version and update Minecraft
  • Mods with a subdirectory root
  • Inactive mods -> gray
  • Better conflict detection
  • Startup screen size
  • Configurations
  • Minecraft font
  • “Add mods” to start in Minecraft directory
  • Select java executable, custom java parameters
  • Native executable for Mac (app)
  • Select minecraft directory (libs, lwjgl jars, resources)
  • Future (backups, downgrade/upgrade)

Note : if this Magic Launchernot work try to install ModLoader first

This is another popular mods or beeing popular create by sp614x, you really rock!. We still looking for latest updates for both features and detail information about Magic Launcher, so to those of you whose already using this mod can share some tips, trick of even tutorial and please do not be hesitate, feel free to. OK minecrafters, this is it, until next post on another minecraft things we need to know. See you soon guys and thank you for visiting my post about Magic Launcher

Download Magic Launcher (Windows)

Download Magic Launcher (Mac / Linux)

Download Magic Launcher for Mac and Windows

Incoming search terms:

  • magic launcher
  • minecraft launcher
  • minecraft magic launcher
  • minecraft launcher download
  • magic launcher download
  • magiclauncher
  • minecraft mod launcher
  • download minecraft launcher
  • magic launcher 1 7 2
  • yhsm-inucbr_001

Tags: , , , , , , ,



96 thoughts on “Magic Launcher 1.7.10/1.7.9/1.7.2”

Looks like the mod was incompatible with the Magic Launcher. Try using MCPatcher and download Modloader and ModloaderMP. Easy as it?

I always get this error when i’m trying to start minecraft.. it gives me the same error with and without mods installed..
help?

MagicLauncher 0.9.7
java.home: C:\Program Files\Java\jre6
java.runtime.name: Java(TM) SE Runtime Environment
java.runtime.version: 1.6.0_27-b07
os.name: Windows 7
os.version: 6.1
os.arch: x86
sun.arch.data.model: 32

*** Starting Minecraft ***
Minecraft version: 1.2.3
Minecraft.jar: minecraft.jar
Mods:
OptiFine_1.2.3_HD_MT_B.zip
Java path: C:\Program Files\Java\jre6\bin\java
Memory: 2046 MB
LauncherPath: /C:/Users/********/Downloads/MagicLauncher_0.9.7.exe
Error occurred during initialization of VM
Could not reserve enough space for object heap
Could not create the Java virtual machine.

That’s most likely because minecraft was updated to 1.2.4 recently, you’ll have to go without magic launcher until it’s updated.

“Error occurred during initialization of VM
Could not reserve enough space for object heap
Could not create the Java virtual machine.”

reduce the amount of memory you are starting it with, right now you have it trying to reserve 2GB of ram, and it’s not able to reserve that much, (perhaps something else is using reserved ram and you are low on available?)

I have a proble, whenever I activate redstone, it reloads the chunk, which is pretty annoying. However, it’s great! Thank yuo for it.

To the above problem with the error code: Simply go to the setup screen -> Advanved And turn down the amount of space you dedicate to it. Try 1500 first, if that still doesnt work then try 1200, if that still refuses stick with 1050

I have mac…. and i dont understand how you get mods to go in…… ive tryed to put the name of the folder in the thing but dat dont work… HELP ME PLEASE

It is probrobly because it is a mod that needs to be installed in the minecraft jar such as turbo model thingy,or you just broke your launcher.

this ballsucks,i cant even click,i click on downlaod,it displays downlaod music,i click on download word,etc it shows soem sort of search page(similiar to google)

lets go boah new minecraft update yeah woooooo so that minecraft update we was talking about that minecraft looks cool and it should be fun so if goin to get you better say yes because whould if you play that game day you going to be tired because you was the all day

just curious, if you delete META-INF to install something that cannot be installed with MagicLauncher, does it crap out on you? I got this error message:

java.lang.NoClassDefFoundError: PlayerBase
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(Unknown Source)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.security.SecureClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.access$000(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at net.minecraft.move.playerapi.SmartMoving.register(SmartMoving.java:27)
at mod_SmartMoving.modsLoaded(mod_SmartMoving.java:83)
at ModLoader.init(ModLoader.java:899)
at ModLoader.addAllRenderers(ModLoader.java:189)
at ahu.(RenderManager.java:86)
at ahu.(RenderManager.java:14)
at net.minecraft.client.Minecraft.a(Minecraft.java:394)
at net.minecraft.client.Minecraft.run(Minecraft.java:732)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.ClassNotFoundException: PlayerBase
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
… 20 more
— END ERROR REPORT 27533228 ———-

That’s what it said. Help?

The problem is, that the mod folder is filled with lots of files, EG:
SmartMoving mod: When you open it it shows you LOTS of smartmoving files, this is a problem, you need to drag the file that has the class files to somewhere on your desktop, THEN you “Add” it on Magic Launcher. It works for me.
Later gator

when i try to download magic launcher, all it does is goes to a page with nothing but an advertisement and the words “preparing download request” and it does not change whatsoever no matter how long i wait
help please im not good with mods so i need this magic launcher

EVERY ONE TO GET THE MODS ONTO THE SCREEN U MUST DOWNLOAD MODS SO ITS IN A ZIP FILE… DON’T EXTRACT IT! THEN WHEN YOU’RE CHOOSING YOUR MODS IN THE LAUNCHER YOU CLICK ON THE .ZIP FILE… FOR EXAMPLE YOU WOULD CLICK ON ModloaderMP.zip to load mod loader mp.

hope this helps….

my problem/question is this: my modloader says “not compatible” and it wont work and like all mods need it. any suggestions???

thx

Here’s a suggestion:

Wait for MagicLauncher to become compatible with the new 1.3.1 update of minecraft. Should be soon now.

Did you compile the mod right before you installed it? Magic launcher will accept zipped files if they are compressed versions of the class files, not the folder they are contained in.

I downloaded Magic Launcher and then put in Modloader and Too Many Items and it worked fine. Then when I put in Opti Fine it said there are 18 errors. I don’t know what to do, could someone help me? And they are all the newest versions, I made sure of that.

For Too Many Item it says that it’s a duplicate mod, for Clay Soldiers it says no mod found, so far the only things working are Too Many Items and Modloader. I don’t know what to do.

If anybody can read this: GET THE MAGIC LAUNCHER! This has been one of the best things I have ever downloaded, right next to Alfred. (an app for the mac)

bob and bobzers make forge is at the top of the mods section. u can do this by clicking on forge and then clicking on “up”

….the hell’s so special about this one. it’s the same thing i downloaded 23 days ago when 1.3.2 was the latest version.

get the latest forge update….it has modloader built in. i run: rei minimap, paxels, death chest, more bows, timber!, shibby’s fly mod, decoratives, finder compass and IC2. they all work.

*** MagicMinecraftLauncher 1.0.0 ***
java.lang.VerifyError: (class: net/minecraft/client/Minecraft, method: O signature: ()V) Incompatible argument to function
at java.lang.Class.getDeclaredMethods0(Native Method)
at java.lang.Class.privateGetDeclaredMethods(Unknown Source)
at java.lang.Class.getMethod0(Unknown Source)
at java.lang.Class.getMethod(Unknown Source)
at magic.launcher.Launcher.main(Unknown Source)

Any help?

same here. i’ve tried deleting meta inf, doesn’t work. tried installing modloader before starting magiclauncher, still didn’t work. don’t know what else to try here.

You should make have an ID resolver too, so it can help make the mods compatible, if it doesn’t already.

Hi, I had Magic Launcher and my mods worked fine recently they have 1,12,17, and 9 errors? I try starting Minecraft and the screen stays black. Help?

Oh,I also had downloaded a Minecraft Launcher not the magic launcher and the screen went totally black too.My suggestion is that you just have to download a new one.

i wanna install optifine and single player commands but it says the status is “internal mod” what does that mean?

i had a problem, i run magic launcher, then put the mods, then press “test”. Ok, but then, when i play minecraft, there are no mods. I have TMI 1.6.2 and instant massive structures 1.6.2,

i used magic launcher i deselected my external mods, then magic launcher deleted it all from my mod folder, where do they end up?

hey, when i tried to putchocapic13 shaders mod on, it comes up with IOexception, how do i fix this??? Plz help!!!

can someone help me i got the mod loader on magic launcher and on its status it says it has 11 errors and when i try to start the game it instantly closes on me and nothing happens

When I try to use magic launcher, it says this:
MainClass: net.minecraft.client.Minecraft
java.lang.ClassNotFoundException: net.minecraft.client.Minecraft
at java.net.URLClassLoader$1.run(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at magic.launcher.Launcher.main(Unknown Source)
Can anyone help?

I do also have a terrible problem with magic launcher. It started with 1.6.2. version and now with 1.6.4

When i start using it it is unreadeable, seems arabic signs or programming signs instead of normal english.
Sometimes the first page showing latest info is in english but all buttons show arabic.
Since i am not the onlyone having this i ask for a helping hand here.
I use pc with win7, latest java, minecraft 1.6.4 and magic launcher 1.1.7
I am on a server with more people and none has the same problem.
Minecraft wiki also is showing the problem with at least two screendumps but nobody did response.
Help out please

Leave a Reply

Your email address will not be published. Required fields are marked *