Equivalent Exchange 3 Mod 1.7.10/1.7.2

By | Jul 2, 2014

Equivalent Exchange 3 Mod – Download Equivalent Exchange Mod for Minecraft. Hello minecrafters! this is you waiting for, One of most popular mods has been update and now working fine with the latest minecraft. This Equivalent Exchange 3 Mod allows you to transmute tons of materials into other materials. It adds a lot of what is classified by many as “endgame content”, to make you feel more godlike in your sandbox world. If this offends your Minecrafting sensibilities, this may not be the mod for you. So guys! want to download and install this Equivalent Exchange 3 Mod ? see my post below

Equivalent Exchange 3 Mod

With this Equivalent Exchange 3 Mod you can adds many new powerful items to the game that gives you new powers and abilities. It also adds new tools, armor, item repair, more blocks, and more. You need to try this mod in order to understand how great it really is. How to usage this Equivalent Exchange 3 Mod? in order to use any of the new features in this mod you will have to first craft a Philosopher’s Stone. But the most thanks goes to the developer of equivalent exchange mod, x3n0ph0b3. If you have time, visit the original page for more information on blocks and awesome items! (+ Recipe) from this Equivalent Exchange 3 Mod

Equivalent Exchange 3 Mod 1.7.10/1.7.2

Equivalent Exchange 3 Mod Changelogs

  • updated to latest Minecraft!
  • updated version number from 1.38 to 1.4.3.1. Allows for better tracking of updates to the version
  • now using Minecraft Forge 6.4.0.x.x or higher
  • added a max world height constant to the client/server EEProxy class
  • changed the Water Essence and Lava Essence to check Y position against the new maximum world height for changing the weather
  • added EMC mappings to client for:
  • Redstone Lamp
  • Nether Brick Fence
  • Nether Brick Stairs
  • Wood (Jungle)
  • Leaves (Jungle)
  • Sapling (Jungle)
  • Stone Bricks (Circle)
  • Fireball Charge
  • Ferns
  • Grass
  • modified the loading of the addon modules to check whether or not the mod in question is loaded or not before attempting to initialize
  • using the BC 3.x API now instead of the BC 2.x API
  • fixed crash bug where players place an EE TE at y=1. Only a concern when in creative mode and breaking the bedrock at y=1 to place items
  • updated the transmutation of NPCs to include the new NPC types introduced from 1.0 onwards
  • can now transmute Snow Golems to Iron Golems! Provided you have enough reagents to cover the cost
  • fixed bug with Collector Mk2’s not being able to accumulate more than 3000 latent EMC
  • made the clients aware of the alternate relay recipe. replace the collector mk1 with a diamond block for the alternate recipe. useful on servers where collectors are disabled.
  • fix in the Pedestal GUI displaying “container.inventory” vs “Inventory”

Equivalent Exchange 3 Mod Items

  • The Philosopher’s Stone
  • Dark Matter
  • Base Ring
  • Dark Matter Tools
  • Dark Matter Pickaxe
  • The Dark Matter Shovel
  • The Dark Matter Hoe
  • The Dark Matter Sword
  • Dark Matter Axe
  • Dark Matter Shears
  • Dark Matter Armor Set
  • The Destruction Catalyst
  • and Many more..

Equivalent Exchange 3 Mod Installtions for Minecraft

  1. Install the required version of Minecraft Forge in to you minecraft.jar
  2. Download Equivalent Exchange 3 Mod
  3. Put ‘ee3-universal-v####.jar’ in to your /mods folder
  4. Load up Minecraft and play!
  5. Enjoy

Ok, minecrafters is there anything else you would like to add? especially information about Equivalent Exchange 3 Mod changelogs, latest details and features update. You can share by comment below to complete this Equivalent Exchange 3 Mod post. Thank you for visiting and see you soon on another minecraft mod post category or update from Equivalent Exchange 3 Mod

Download Equivalent Exchange 3 Mod 1.6.4

Download Equivalent Exchange 3 Mod 1.7.2

Download Equivalent Exchange 3 Mod 1.7.10

Incoming search terms:

  • equivalent exchange 2
  • equivalent exchange 1 6 4
  • minecraft equivalent exchange
  • equivalent exchange mod
  • equivalent exchange
  • equivalent exchange 1 7 10
  • equivalent exchange 2 1 7 10
  • EquivalentExchange3Mod1 7 10/1 7 2 DownloadMinecraft
  • equivalent exchange minecraft
  • Equivalent Exchange Mod 1 7 10

94 thoughts on “Equivalent Exchange 3 Mod 1.7.10/1.7.2

  1. neomortalgirl

    someone plzzzzzzzzzz help me i install it correctally and it just says updating minecraft and stays there

    Reply
    1. Someone

      Make a mod folder and put it in. if that doesnt work, did you delete META.INF? Try both.

      Reply
        1. HurrDurr

          Open your .minecraft file, go to the bin folder, right click minecraft.jat and open with 7zip/ winrar or winzip (forgot which one)

          Reply
          1. TROLOLOLOLOL

            actualy i dont have meta-inf on mine so i was like WTF WHERE IS IT not there it works fine with out deldting it

          2. DaEpik1

            minecraft.jar and it doesn’t matter which

        2. braydon

          it is in the minecraft folder opin it with 7zip or wirar an it will be right there

          Reply
    2. Broncoboy

      The ad-fly website takes me to the drop box but it says it doesnt know where the download is????
      Someone plz help me !!!!!

      Reply
    3. bloopdedoop

      me too!! its so annoying!! i just left it there for it to load, but it never did!!

      Reply
    4. raseran

      OMG guys Just get tekkit its alot better than this it has all the mods installed tmi and everything!!!!!!!!!!!!!!!!!!!!!!

      Reply
      1. Happywizard1

        Hey dont get tekkit it is only for nobs who cant actually download mods even though it has them it is a lot less nobber just doing it ur self. :)

        Reply
        1. git

          the yogscast have a tekkit lets play nearly 70 episodes long and they have nearly 3 million subscribers on youtube. calling them nobs?

          Reply
          1. owlgrandecity

            They technically are noobs. Duncan, even if he knows EVERYTHING about Tekkit, he is a dumb-wit when it comes to vanilla. They just play the popular ones, how about FTB, where it actually has the permission of the modmakers? Tekkit doesn’t. That’s why Tekkit almost got shut down if it didn’t become famous.

          2. ddj5436

            Hmm i know this was awhile back but they make there own modpacks which i consider pretty unnooby plus they have there own feed the beast pack.

        2. fldatatek

          hey man I’m a big minecraft modder I have like 25 mods now downloaded on my minecraft and I still play tekkit cuz it is fun dont just make broad statements like that and it is noob and noobs not nob

          Reply
          1. MrTroll

            You are not a modder if you modded your Minecraft.
            A modder is a guy who creates mods.

          2. peter

            well accualy 25 mods isn’t vry much i alredy have putted in 37 mods in one day

      2. ferrettomato

        It’s not TMI (Too Many Items), it’s NEI(Not Enough Items). TMI Doesn’t have Item Subsets, or a Heal Player button.

        Reply
      3. Pete

        Its Not Enough Items not Too Many Items, and yes they are different

        Reply
    5. Helppper

      Force update install it again if its not working then your minecraft.jar is corrupted to fix that get fml (Forge mod loader) and put the mod folder in the “Mods” and no files of EE in the minecraft.jar ONLY in the mods folder. if u already have done that tell me Error code ur opperative system or make a msg the owner of the mod asking how to fix.

      Reply
    6. Brandon

      why didnt i get dark or red matter and alot of other stuff in this mod?

      Reply
      1. Destractias2

        me too! i dint get all the other stuff like dark and red matter
        or energy collectors or even a energy condenser!

        Reply
        1. Tyeia

          This is EE3 not EE2 they decided to wipe to clean slate pretty much aka getting rid of every item except for phil stone and alch bags

          Reply
          1. Brian

            Is there a way to get EE2 for 1.4.7?

      2. Yolo

        Dark matter stuff is in the equivalent exchange mod which is only included in the tekkit CLASSIC

        Reply
    7. Bruce lee the second

      Make sure u deleted META-INF in your minecraft.jar

      Reply
    8. TeoZ02

      with minecraft 1.6.2 my minecraft stop work, but with minecraft 1.5.2 the ee3 works perfectly! Save a backup of /saves folder and delete .minecraft, then launch minecraft. go to the new .minecraft folder, put in the backup of /saves folder then open /bin, open /minecraft.jar with winrar, delete META.INF. copy in minecraft.jar the forge files then run minecraft. after the loading, close minecraft. comy in /mods folder the ee3 jar file. Finish! now minecraft should work.

      Reply
    1. Sir Malican

      Of course it works! It wouldn’t BE here if it didn’t work!!!

      Reply
  2. feezey265

    Ok, i need some help. I installed everything, no black screen or anything but my FURNACES of anything that could go wrong dont work! They dont stack items i put inside them, they just “poof” please help!

    Reply
  3. philip

    someone help i cant find the minecraft.jar!!! i search it and it says there are no matches!?!?!?!?!?

    Reply
      1. Someone

        You need winrar godamnit. its not a hdden folder.

        Reply
  4. Sigurd

    Same problem applies for me… Left a stack of cobblestone to burn, and when i came back there was only one left…

    Reply
    1. huchairn

      is there a chest next to it .. it may be sucked into there

      Reply
  5. Ray

    The download for me just brings up mediafire and says “upload files” and nothing is downloading.

    Reply
  6. midnightphoenix

    it says error 369… :/ i wanna use this!!! PLZ HELP ME FIX IT

    Reply
  7. somedude

    can someone please give me a working link for 1.1?
    this one appears to be broken.

    Reply
  8. Arazimus

    Hello all, I Have installed several Mods succesfully, and have a question, as I cannot get EE to work… Craft Guide works.. but not EE.

    I have ran into several mods today that “Assure us” they work, but I haven’t been able to successfully install, and I am wondering if there were perhaps recent changes to ModLoader, ModLoader MP or Minecraft Forge, that may have broken these builds? Could someone go download the latest versions of the above, and then do an install to see of they work? Here is my Modloader Log…

    Mar 14, 2012 8:31:40 PM ModLoader init
    FINE: ModLoader 1.2.3 Initializing…
    Mar 14, 2012 8:31:40 PM ModLoader readFromClassPath
    FINER: Adding mods from C:\Users\Joe\AppData\Roaming\.minecraft\bin\minecraft.jar
    Mar 14, 2012 8:31:40 PM ModLoader readFromClassPath
    FINER: Zip found.
    Mar 14, 2012 8:31:40 PM ModLoaderMp Log
    FINE: ModLoaderMP 1.2.3 Initialized
    Mar 14, 2012 8:31:40 PM ModLoader addMod
    FINE: Mod Initialized: “mod_ModLoaderMp 1.2.3” from mod_ModLoaderMp.class
    Mar 14, 2012 8:31:40 PM ModLoader addMod
    FINE: Mod Initialized: “mod_MinecraftForge 1.4.0.51” from mod_MinecraftForge.class
    Mar 14, 2012 8:31:40 PM ModLoader setupProperties
    FINER: EggArrowID set to 10287
    Mar 14, 2012 8:31:40 PM ModLoader setupProperties
    FINER: ExplosiveArrowID set to 10284
    Mar 14, 2012 8:31:40 PM ModLoader setupProperties
    FINER: FireArrowID set to 10285
    Mar 14, 2012 8:31:40 PM ModLoader setupProperties
    FINER: HomingBowID set to 10296
    Mar 14, 2012 8:31:40 PM ModLoader setupProperties
    FINER: IceArrowID set to 10286
    Mar 14, 2012 8:31:40 PM ModLoader setupProperties
    FINER: LightningArrowID set to 10288
    Mar 14, 2012 8:31:40 PM ModLoader addMod
    FINE: Mod Initialized: “mod_Arrows 1.2.3” from mod_Arrows.class
    Mar 14, 2012 8:31:40 PM ModLoader addMod
    FINE: Mod Initialized: “mod_CraftGuide 1.4.3 for Minecraft 1.1.0” from mod_CraftGuide.class
    Mar 14, 2012 8:31:40 PM ModLoader readFromModFolder
    FINER: Adding mods from C:\Users\Joe\AppData\Roaming\.minecraft\mods\1.2.3
    Mar 14, 2012 8:31:40 PM ModLoader readFromModFolder
    FINER: Directory found.
    Mar 14, 2012 8:31:40 PM ModLoader readFromModFolder
    FINER: Adding mods from C:\Users\Joe\AppData\Roaming\.minecraft\mods\BetterDungeons.zip
    Mar 14, 2012 8:31:40 PM ModLoader readFromModFolder
    FINER: Zip found.
    Mar 14, 2012 8:31:40 PM ModLoader addOverride
    FINER: addOverride(/gui/items.png,/bdimg/shied.png,38). 84 left.
    Mar 14, 2012 8:31:40 PM ModLoader addMod
    FINE: Mod Initialized: “mod_betterDungeons 0.921” from mod_betterDungeons.class
    Mar 14, 2012 8:31:40 PM ModLoader readFromModFolder
    FINER: Adding mods from C:\Users\Joe\AppData\Roaming\.minecraft\mods\EE2ModV1.4.0.3.zip
    Mar 14, 2012 8:31:40 PM ModLoader readFromModFolder
    FINER: Zip found.
    Mar 14, 2012 8:31:40 PM ModLoader addMod
    FINE: Failed to load mod from “mod_EE.class”
    Mar 14, 2012 8:31:40 PM ModLoader addMod
    FINER: THROW
    java.lang.NoSuchMethodError: ModLoaderMp.initialize()V
    at mod_EE.(mod_EE.java:87)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    at java.lang.Class.newInstance0(Unknown Source)
    at java.lang.Class.newInstance(Unknown Source)
    at ModLoader.addMod(ModLoader.java:293)
    at ModLoader.readFromModFolder(ModLoader.java:1283)
    at ModLoader.init(ModLoader.java:886)
    at ModLoader.addAllRenderers(ModLoader.java:186)
    at aho.(aho.java:79)
    at aho.(aho.java:9)
    at net.minecraft.client.Minecraft.a(Minecraft.java:395)
    at net.minecraft.client.Minecraft.run(Minecraft.java:732)
    at java.lang.Thread.run(Unknown Source)
    Mar 14, 2012 8:31:50 PM ModLoader init
    FINE: Mod Loaded: “mod_ModLoaderMp 1.2.3”
    Mar 14, 2012 8:31:50 PM ModLoader init
    FINE: Mod Loaded: “mod_MinecraftForge 1.4.0.51”
    Mar 14, 2012 8:31:50 PM ModLoader addOverride
    FINER: addOverride(/gui/items.png,/arrows/eggarrow.png,102). 83 left.
    Mar 14, 2012 8:31:50 PM ModLoader addOverride
    FINER: addOverride(/gui/items.png,/arrows/exarrow.png,118). 82 left.
    Mar 14, 2012 8:31:50 PM ModLoader addOverride
    FINER: addOverride(/gui/items.png,/arrows/fiarrow.png,119). 81 left.
    Mar 14, 2012 8:31:50 PM ModLoader addOverride
    FINER: addOverride(/gui/items.png,/arrows/hombow.png,120). 80 left.
    Mar 14, 2012 8:31:50 PM ModLoader addOverride
    FINER: addOverride(/gui/items.png,/arrows/icearrow.png,134). 79 left.
    Mar 14, 2012 8:31:50 PM ModLoader addOverride
    FINER: addOverride(/gui/items.png,/arrows/liarrow.png,144). 78 left.
    Mar 14, 2012 8:31:50 PM ModLoader init
    FINE: Mod Loaded: “mod_Arrows 1.2.3”
    Mar 14, 2012 8:31:50 PM ModLoader init
    FINE: Mod Loaded: “mod_CraftGuide 1.4.3 for Minecraft 1.1.0”
    Mar 14, 2012 8:31:50 PM ModLoader init
    FINE: Mod Loaded: “mod_betterDungeons 0.921”
    Mar 14, 2012 8:31:50 PM ModLoader addAllRenderers
    FINE: Initialized

    Reply
    1. Arazimus

      OK, I had an outdated version of ModLoader MP. Problem Solved….

      Reply
  9. Luckystrike

    ok, i have installed all the required mods, all 1.2.3, but EE still dont work,and minecraft crashes. i have installed everything in order, testing all mods per install. all work upto EE. i have deleted the META-INF folder and all. Nothing works, what do i do?

    Reply
  10. Anonymous

    The link is broken and it won’t download. Its giving me a dropbox error saying the file isnt there. Is this the case for everyone else??

    Reply
  11. Zenith

    Help! I am running MC 1.2.4 and I got this following error when I tried to start the game:

    Mods loaded: 5
    ModLoader 1.2.4
    mod_CraftGuide 1.4.3 for Minecraft 1.1.0
    mod_MinecraftForge 2.0.0.67
    mod_ModLoaderMp 1.2.4v1
    mod_EE 1.4.1.5

    Minecraft has crashed!
    ———————-

    Minecraft has stopped running because it encountered a problem.

    — BEGIN ERROR REPORT 3d80c377 ——–
    Generated 3/31/12 10:41 PM

    Minecraft: Minecraft 1.2.4
    OS: Windows 7 (amd64) version 6.1
    Java: 1.6.0_31, Sun Microsystems Inc.
    VM: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Sun Microsystems Inc.
    LWJGL: 2.4.2
    OpenGL: GeForce GTX 260/PCI/SSE2 version 3.3.0, NVIDIA Corporation

    java.lang.NoSuchMethodError: ym.(I)V
    at CraftGuide.ItemCraftGuide.(ItemCraftGuide.java:14)
    at mod_CraftGuide.addItems(mod_CraftGuide.java:70)
    at mod_CraftGuide.load(mod_CraftGuide.java:41)
    at ModLoader.init(ModLoader.java:891)
    at ModLoader.addAllRenderers(ModLoader.java:189)
    at ahu.(ahu.java:79)
    at ahu.(ahu.java:9)
    at net.minecraft.client.Minecraft.a(Minecraft.java:395)
    at net.minecraft.client.Minecraft.run(Minecraft.java:732)
    at java.lang.Thread.run(Unknown Source)
    — END ERROR REPORT efe2dcc2 ———-

    Reply
    1. blah

      update all your mods to 1.2.4

      i.e craftguide is for 1.1,needs to be 1.2.4

      Reply
    2. a little help

      Modloader and Forge aren’t compatible with each other.

      Reply
  12. jason

    Just gives me a 404 page after the ad fly stuff. Anyone have the newest 1.4.0.3 and a link that works?

    Reply
  13. sunsetman

    i use skcraft to easily add mods in, and that didn’t work, so, i did it manually as show above, and it doesn’t seem to be working….

    Reply
  14. g

    OMG I INSTALLED IT PERFECTLY AND IT IS FRZEN ON THE MOJANG SCREEN

    Reply
    1. Alec

      Yeah, me too. I installed each mod individually (Put in the ‘Audiomod’ files, tested Minecraft, repeat) and it’s all fine until I place in the EE2 files. Then I get frozen at the Mojang screen like G did.

      Reply
  15. shoot...

    well i cant find the equivalent echange.zip …. i downloaded the equivalent exchange and i cant find it… HELP!!

    Reply
  16. JAJA

    The download doesn’t work it takes me to kind of a notepad thing that says EE2 v1.4.3.1 changelog
    ========================
    For Minecraft v1.2.5

    Requires:
    – Risugami’s ModLoader v1.2.5
    – MinecraftForge v3.0.0.72

    Misc:
    * Updated to the latest Forestry API
    and it doesnt say the download

    Reply
  17. Walter

    Don’t work with the lastest updated of Forge (3.0.0.84), I had to download version 3.0.0.72

    Reply
  18. bob

    the link is broken/ not working

    i checked it loads of times and still nothing please fix it

    Reply
  19. Patrick

    need help! stuck at done updating screen after downloading all previous mods before EE, don’t know what to do, everything is 1.5, AudioMod, Craft Guide, Both Modloader and Modloader MP and FORGE API, HELP

    Reply
  20. Jack

    help cant get EE working+crafting guide no working+minecraft crashes every 2 minutes. Did every thing still not working

    Reply
  21. Set Sail for Fail

    Ohp! Fixed it, java was trying to open a .class as a .jar this whole time like, “Omg, what is this, I don’t even” because I put the EE2Modv1.4.3.1.jar into the mods folder all by itself. To fix it, I added an “EE2” folder and shoved the .jar in there, then java opened up the folder instead of the .jar, then ran the .jar instead of the .class.

    Works perfectly. Thank you, Legion of the Anonymous.

    Reply
  22. sean

    Wheres the Energy Condenser and Energy collector two very important items if ones wants to create a nuclear reactor following the easy tutorial on the tekkit wiki.

    Reply
  23. Kingsley

    Wow there is nothing in this pre-release how do i get the real one?

    Reply
  24. joda

    i tried to do it in 1.4.2 but it glitches my inventory and i only got philophisers stone from the mod

    Reply
  25. Connor Lang

    Why the hell does EE3 require MinecraftForge AND Modloader? Why the fuck does ANY mod require Modloader anyways? They should just be able to be installed ALONE goddamnit.

    Reply
  26. melispanda

    Will there be a Modloader version of this mod like before? I’d love to have this mod again, but I can’t get Forge to work for me. It always crashes my game and once crashed my whole laptop(I have a TERRIBLE computer. Barely runs Minecraft normally).

    Reply
  27. michael

    I installed it rigth and worked except all that it show’s in my not enough
    items is the philosophers stone Can someone help is it because i have notenought items or do i need a nother .jar

    Reply
  28. pagerrager

    I installed the mod correctly, but none of the things that are in the mod are in there. There are some new things that weren’t in there before, such as “red water” , “minium” , “inert stone”, and the philosopher’s stone doesn’t work at all.

    Reply
  29. Klodde

    i download and instal , it runs it but i only have a few items : all the dusts the philosepher’s stone and shard of mimium mimium stone and anothere stone why?

    Reply
  30. Nohbdy

    None of the mods in my mod folder work, they just don’t exist in-game. Help?

    Reply
  31. Randall

    I installed the ee3 mode started minecraft works fine. But, when i go to chcke NEI i dont have any Dark matter/red matter all i have is phlosphers stones and indolaseacence dust

    Reply
  32. Ollie

    I Have the same problem too! Is there any way of fixing it? :(

    Reply
  33. David

    i need help cause i downloaded it but all i got was a philosopher stone! and some dust

    Reply
  34. Kirester

    Okay guys. for the 1.4.5 download, the reason you are only getting the philo stone and a few dusts is because it is a pre-release of EE3 (as indicated by the file name) the version that was dark/red matter and everything is EE2, a full version. the authors of this mod are working of finishing EE3; and were kind enough to give us a preview of it (ee3-universal-pre1)

    Reply
  35. Jds

    I have tried several times to install this mod, it seems to install correctly but when i go to my inventory in creative I only find a handful of items and I know there should be more than the 5 or 6 that appear and idea whats happening?

    Reply
  36. slynesh

    people help having problem with EE for some reason when i download client and put it to mod folder it wont give me any new stuff and im wondering why and how am i supposed to get it workin.

    Reply
  37. Josh-2622

    The reason the items are “not working” is because this is EE# (Equivalent Exchange 3) not EE2. EE2 had all the items “fleshed out” so to speak, whereas ee3 is just a new mod that pahimar has started. all those items you’re looking for don’t exist anymore, as Pahimar said he would no longer be supporting EE2, nor did he give permission for anyone else to support i. Basically, you have what you’re supposed to until he finishes EE3 and updates it.

    Reply
    1. dirtywastegash

      well what a joke…. someone should update this post as this mod description is not totally inaccurate.
      VVV none of this exists in ee3 yet and most of it NEVER will
      Dark Matter
      Base Ring
      Dark Matter Tools
      Dark Matter Pickaxe
      The Dark Matter Shovel
      The Dark Matter Hoe
      The Dark Matter Sword
      Dark Matter Axe
      Dark Matter Shears
      Dark Matter Armor Set
      The Destruction Catalyst
      and Many more..

      Reply
  38. Steven

    Guys just get tekkit ! Its got this and alot more mods !

    Reply
  39. Desfang

    I have it installed but a lot of the items aren’t showing up.

    Reply
  40. bavs01

    HELP! I installed to minecraft 1.4.7 but there isnt transmutation tablet, or alchemical chest… How can I get them?

    Reply
  41. Gustav

    Either this is just a trick to get downloads or else the original creators of the EE’s has replaced the download with the real Ee3

    Reply
  42. (^FACEPALM^)!!!!

    Wow this is madness!!!
    just go and read all the comments till now and you get my point =?

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *